博易主图 趋势为王指标

  • A+
所属分类:博易大师

AS:=(C*3+O+H+L)/6;
 XJ:=(AS+0.618*REF(AS,1)+0.382*REF(AS,2)+0.236*REF(AS,3)+0.146*REF(AS,4))/2.382;
 
HLX:=EMA(HHV(XJ,3),15);
 LLX:=EMA(LLV(XJ,3),15);
 CH:=CROSS(XJ,HLX);CL:=CROSS(LLX,XJ);
 CHH:=BARSLAST(CH);CLL:=BARSLAST(CL);
 YF1:=(CHH<CLL OR CH) AND NOT(CL);
 YF2:=(CHH>CLL OR CL) AND NOT(CH);
 TF:=IF(YF1,LLX,HLX);
 TFB:=(HLX+LLX)/2;
 
XJK:=SMA(EMA(XJ,3),3,1);
 ZWSH:=(HHV(XJ,2)+HHV(XJ,3)+HHV(XJ,4)+HHV(XJ,5))/4;
 SH:=EMA(ZWSH,21);
 ZWSL:=(LLV(XJ,2)+LLV(XJ,3)+LLV(XJ,4)+LLV(XJ,5))/4;
 SL:=EMA(ZWSL,21);
 SCH:=CROSS(XJ,SH);SCL:=CROSS(SL,XJ);
 SHH:=BARSLAST(SCH);SLL:=BARSLAST(SCL);
 SF1:=(SHH<SLL OR SCH) AND NOT(SCL);
 SF2:=(SHH>SLL OR SCL) AND NOT(SCH);
 TFS:=IF(SF1,SL,SH);
 TFBS:=(SL+SH)/2;
 {K线}
 KX1:=(CLOSE>=OPEN) AND XJ>=TFS;
 KX2:=(CLOSE<OPEN) AND XJ>=TFS;
 KX3:=(CLOSE>=OPEN) AND XJ<TFS;
 KX4:=(CLOSE<OPEN) AND XJ<TFS;
 KX5:=((XJ>=TFS AND XJ<TF)OR (XJ<TFS AND XJ>=TF)) AND CLOSE>=OPEN;
 KX6:=((XJ>=TFS AND XJ<TF)OR (XJ<TFS AND XJ>=TF)) AND CLOSE<OPEN;
 

FILLRGN(XJ>TFS,TFB,TFS),COLOR400040;
 FILLRGN(XJ<TFS,TFB,TFS),COLOR800000;
 FILLRGN(XJ>TF,TFB,TF),COLOR000060;
 FILLRGN(XJ<TF,TFB,TF),COLORFF2020;
 {K线}
 STICKLINE(KX1,C,O,4,1),COLOR4440FF;
 STICKLINE(KX1,C,H,0.5,1),COLOR4440FF;
 STICKLINE(KX1,O,L,0.5,1),COLOR4440FF;
 STICKLINE(KX2,C,O,4,0),COLOR4440FF;
 STICKLINE(KX2,O,H,0.5,0),COLOR4440FF;
 STICKLINE(KX2,C,L,0.5,0),COLOR4440FF;
 STICKLINE(KX3,C,O,4,1),COLORFFFF33;
 STICKLINE(KX3,C,H,0.5,1),COLORFFFF33;
 STICKLINE(KX3,O,L,0.5,1),COLORFFFF33;
 STICKLINE(KX4,C,O,4,0),COLORFFFF33;
 STICKLINE(KX4,O,H,0.5,0),COLORFFFF33;
 STICKLINE(KX4,C,L,0.5,0),COLORFFFF33;
 {STICKLINE(KX5,C,O,4,1),COLOR5E5E5E;
 STICKLINE(KX5,C,H,0.5,1),COLOR5E5E5E;
 STICKLINE(KX5,O,L,0.5,1),COLOR5E5E5E;
 STICKLINE(KX6,C,O,4,0),COLOR5E5E5E;
 STICKLINE(KX6,O,H,0.5,0),COLOR5E5E5E;
 STICKLINE(KX6,C,L,0.5,0),COLOR5E5E5E;}

博易主图 趋势为王指标

 

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: