K线实体价位重叠主图 (有未来函数) 选股 通达信

  • A+
所属分类:通达信公式

K线实体价位重叠主图 (有未来函数) 选股 通达信

K线实体价位重叠,形成盘整形态。
画线开始是从实体价位向上  或者向下脱离开始。N参数可调节。可根据自己操盘习惯选择3   4  5   6等等。
我这里设置5   表示最近5天K线实体价位重叠,形成行下 或者向上的盘整格局。
主图为了方便大家直观,用到未来函数。
选股没有未来函数

{主图}

N:=5;
S:=MAX(C,O);
X:=MIN(C,O);
A:=X>REF(S,1) OR S<REF(X,1);
XG:=HHV(X,N)<=LLV(S,N) AND COUNT(A,N)>0;
Q:=BACKSET(XG,N);
QD:=BARSLAST(CROSS(Q,0.5));
G:=REFX(LLV(S,N),N-1);
D:=REFX(HHV(X,N),N-1);
HH:=REFX(HHV(H,N),N-1);
LL:=REFX(LLV(L,N),N-1);
DRAWLINE(QD=0,G,XG,LLV(S,N),0),COLORGREEN;
DRAWLINE(QD=0,D,XG,HHV(X,N),0),COLORGREEN;
DRAWLINE(QD=0 AND S<REF(X,1),HH,XG AND REF(S<REF(X,1),N-1),HHV(H,N),0),DOTLINE,COLORBLUE;
DRAWLINE(QD=0 AND S<REF(X,1),LL,XG AND REF(S<REF(X,1),N-1),LLV(L,N),0),DOTLINE,COLORBLUE;
STICKLINE(QD=0 AND S<REF(X,1),HH,LL,0,-1),COLORBLUE;
STICKLINE(XG AND REF(S<REF(X,1),N-1),HHV(H,N),LLV(L,N),0,-1),COLORBLUE;
DRAWLINE(QD=0 AND X>REF(S,1),HH,XG AND REF(X>REF(S,1),N-1),HHV(H,N),0),DOTLINE,COLORMAGENTA;
DRAWLINE(QD=0 AND X>REF(S,1),LL,XG AND REF(X>REF(S,1),N-1),LLV(L,N),0),DOTLINE,COLORMAGENTA;
STICKLINE(QD=0 AND X>REF(S,1),HH,LL,0,-1),COLORMAGENTA;
STICKLINE(XG AND REF(X>REF(S,1),N-1),HHV(H,N),LLV(L,N),0,-1),COLORMAGENTA;           

 

{选股}

 

N:=5;
S:=MAX(C,O);
X:=MIN(C,O);
A:=X>REF(S,1) OR S<REF(X,1);
HHV(X,N)<=LLV(S,N) AND COUNT(A,N)>0;
 

K线实体价位重叠主图 (有未来函数) 选股 通达信

K线实体价位重叠主图 (有未来函数) 选股 通达信

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: