通达信公式一阳多线及选股

  • A+
所属分类:通达信公式

通达信公式一阳多线及选股

X1:=MA(C,5);
X2:=MA(C,10);
X3:=MA(C,20);
X4:=MA(C,60);
X5:=MA(C,120);
X6:=MA(C,250);
CX1:=L<X1 AND C>X1;
CX2:=L<X2 AND C>X2;
CX3:=L<X3 AND C>X3;
CX4:=L<X4 AND C>X4;
CX5:=L<X5 AND C>X5;
CX6:=L<X6 AND C>X6;
XX:=CX1+CX2+CX3+CX4+CX5+CX6;
DRAWNUMBER(XX>=3,0.5,XX),COLORYELLOW;
STICKLINE(XX>=3,0,0.5,0,0),COLORYELLOW;
Y1:=EMA(C,5);
Y2:=EMA(C,10);
Y3:=EMA(C,20);
Y4:=EMA(C,60);
Y5:=EMA(C,120);
Y6:=EMA(C,250);
CY1:=L<Y1 AND C>Y1;
CY2:=L<Y2 AND C>Y2;
CY3:=L<Y3 AND C>Y3;
CY4:=L<Y4 AND C>Y4;
CY5:=L<Y5 AND C>Y5;
CY6:=L<Y6 AND C>Y6;
XY:=CY1+CY2+CY3+CY4+CY5+CY6;
DRAWNUMBER(XY>=3,0.8,XY),COLORLIRED;
STICKLINE(XY>=3,0.5,1,0,0),COLORLIRED;
DRAWTEXT_FIX(1,0,0,0,"粉红色为EMA线"),COLORLIRED;
DRAWTEXT_FIX(1,0,0.5,0,"黄色为MA线"),COLORYELLOW;

{
XX:=1;
X1:=IF(XX=0,MA(C,5),EMA(C,5));
X2:=IF(XX=0,MA(C,10),EMA(C,10));
X3:=IF(XX=0,MA(C,20),EMA(C,20));
X4:=IF(XX=0,MA(C,60),EMA(C,60));
X5:=IF(XX=0,MA(C,120),EMA(C,120));
X6:=IF(XX=0,MA(C,250),EMA(C,250)),COLORLICYAN;
CX1:=L<X1 AND C>X1;
CX2:=L<X2 AND C>X2;
CX3:=L<X3 AND C>X3;
CX4:=L<X4 AND C>X4;
CX5:=L<X5 AND C>X5;
CX6:=L<X6 AND C>X6;
XX:=CX1+CX2+CX3+CX4+CX5+CX6;
XG:XX>=3;
}

通达信公式一阳多线及选股

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: