主力资金买卖等6个指标(通达信公式 副图 源码 测试图)

  • A+
所属分类:同花顺公式

主力资金买卖等6个指标(源码 副图 通用 贴图)

                交易机器人
H1:EMA(C,8);
H2:EMA(H1,20);
VAR1:=(HHV(H,36)-C)/(HHV(H,36)-LLV(L,36))*100;
VAR2:=SMA(VAR1,5,1);
VAR3:=SMA(VAR2,8,1);
VAR4:=CROSS(VAR2,VAR3) AND VAR3< 20;
VAR5:=C>LLV(C,60)*1.13 AND VAR4;
VAR6:=IF(C>200,VAR4,VAR5);
STICKLINE(H1>H2,H1,H2,0,1),colorred;
STICKLINE(H1< H2,H1,H2,0,1),colorgreen;

                  主力资金买卖

资金趋势:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),coloryellow,LINETHICK2;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
主力持仓:EMA(B1,13),POINTDOT,colorred;
STICKLINE(B1-主力持仓>0,B1,主力持仓,5,0),COLOR0000FF;
STICKLINE(B1-主力持仓<0,B1,主力持仓,5,0),COLOR00FF00;

 
                  主控涨跌力道

N:=5;M:=9;
斜率5:(MA(C,10)-REF(MA(C,10),N))/N;
斜率9:(MA(C,10)-REF(MA(C,10),M))/M;
DRAWTEXT(CROSS(斜率5,斜率9),斜率5,'始');
DRAWTEXT(CROSS(斜率9,斜率5),斜率9,'终');

                        爆发趋势线

主力资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), colorred,LINETHICK2;
即将爆发线: 65,COLOR00FF00;
爆发线:80,colorwhite,LINETHICK1;
DRAWTEXT(CROSS(主力资金,爆发线),主力资金,'★爆发!') ,coloryellow;
爆发警戒线: 50,COLOR00FF00;
抄底线:20,colorwhite,LINETHICK2;
DRAWTEXT(CROSS(主力资金,抄底线),主力资金,'★抄底') ,colorwhite;
DRAWTEXT(CROSS(主力资金,爆发警戒线),主力资金,'★加仓') ,colorwhite;
DRAWTEXT(CROSS(主力资金,即将爆发线),主力资金,'★加仓') ,colorwhite;
DRAWTEXT(CROSS(爆发线,主力资金),爆发线,'★空仓') ,colorwhite;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
RE:=CROSS(J,REF(J+0.01,1)) AND X AND J<19;
STICKLINE(RE,0,1,3,0),coloryellow;
CSS:=((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100);
HH:=CROSS(20,EMA(CSS,3));
CE:=REF(HH,1);
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS)/6;
短线出击:=IF(CROSS(短线买点,1) AND (短线买点<30),30,1);
II:=短线出击=30;
合成:CE AND II;
IF(合成,40,20),colormagenta;

                   小牛简单操盘

买线:EMA(C,5),color000999;
卖线:EMA(SLOPE(C,21)*20+C,42),POINTDOT,colorblue,linethick3;
BUY1:=CROSS(买线,卖线);
SEL1:=CROSS(卖线,买线);
STICKLINE(买线>=卖线,LOW,HIGH,0.1,1),colorred;
STICKLINE(买线>=卖线,CLOSE,OPEN,8,1),colorred;
STICKLINE(买线>=卖线,CLOSE,OPEN,10,1),colorbrown;
STICKLINE(买线<卖线,CLOSE,OPEN,10,0),colorffff00;
STICKLINE(买线<卖线,CLOSE,OPEN,8,0),color00ff00;
STICKLINE(买线<卖线,LOW,HIGH,0.1,1),color00ff00;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,6,0),colorblue;
限制:=EMA((((H+C)/2+L+(C+L)/2)/3-EMA(LLV(((H+C)/2+L+(C+L)/2)/3,89),2))/(EMA(HHV (((H+C)/2+L+(C+L)/2)/3,21),2)-EMA(LLV(((H+C)/2+L+(C+L)/2)/3,89),2)),8)*100;
平衡:=SMA(EMA(SMA((C+L)/2,3,1),3),5,1);
DRAWTEXT(CROSS(买线,卖线),买线,'始');
DRAWTEXT(CROSS(卖线,买线),卖线,'终');

                     潜龙飞天

VAR1:=SMA(AMOUNT,10,1)/1000000;
VAR2:=REF(VAR1,1);
STICKLINE(VAR1>VAR2,VAR1,VAR2,8,0),colorred;
STICKLINE(VAR1< VAR2,VAR1,VAR2,8,0),colorgreen;
潜龙: MA(VAR1,10),colorred;
水面: MA(VAR1,30),coloryellow;
STICKLINE( 水面,0,水面 ,1,0 ),COLOR00FFFF;

主力资金买卖等6个指标(通达信公式 副图 源码 测试图)

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: