通达信CH盘中警示指标公式源码附图

  • A+
所属分类:通达信公式

VAR1:=EMA(CLOSE, 5)/EMA(EMA(CLOSE, 9), 16);
VAR5:=(CLOSE-LLV(LOW, 75))/(HHV(HIGH, 75)-LLV(LOW, 75))*100;
VAR6:=SMA(VAR5, 20, 1);
VAR7:=SMA(VAR6, 15, 1);
VAR8:=100-3*VAR6+2*VAR7;
VAR9:=((EMA(IF(VAR8>REF(VAR8, 1), VAR8, VAR8-3), 3)-50)*(-1)*2/2+50)/10;
VAR10:=EMA(AMOUNT, 13)/EMA(VOL, 13);
VAR11:=(VAR10/REF(VAR10, 1)-1)*100;
VAR12:=VOL/CAPITAL*100;
VAR13:=(HIGH-LOW)/((HIGH+LOW)/2)*100;
VAR14:=(VAR9+VAR12)*VAR13*VAR11;
VAR15:=REF(CLOSE, 1);
VAR18:=(CLOSE-LLV(LOW, 9))/(HHV(HIGH, 9)-LLV(LOW, 9))*100;
VAR19:=SMA(VAR18, 3, 1);
VAR20:=SMA(VAR19, 3, 1);
VAR21:=3*VAR19-2*VAR20;
VAR22:=(CLOSE-LLV(LOW, 26))/(HHV(HIGH, 26)-LLV(LOW, 26))*100;
VAR23:=SMA(VAR22, 6, 1);
VAR24:=SMA(VAR23, 3, 1);
VAR25:=3*VAR23-2*VAR24;
VAR26:=IF(CROSS(VAR21, VAR25) AND VAR25<20, (-1), 0)+IF(CROSS(VAR25, VAR21) AND VAR25>80, 1, 0);
VAR27:=(HIGH+LOW+CLOSE)/3;
VAR28:=(VAR27-MA(VAR27, 14))/(0.015*AVEDEV(VAR27, 14))/2;
VAR29:=SMA(MAX(CLOSE-VAR15, 0), 6, 1)/SMA(ABS(CLOSE-VAR15), 6, 1)*100;
VAR30:=LLV(LOW, 36);
VAR31:=HHV(HIGH, 36);
VAR32:=EMA((CLOSE-VAR30)/(VAR31-VAR30)*100, 9);
VAR33:=IF(VAR28>100 AND VAR32>50 AND CLOSE>OPEN, 0.5, 0)+IF(VAR29>80 AND VAR32>50 AND CLOSE>OPEN, 0.5, 0);
VAR34:=(CLOSE-LLV(LOW, 100))/(HHV(HIGH, 100)-LLV(LOW, 100))*100;
VAR35:=SMA(VAR34, 21, 1);
VAR36:=SMA(VAR19, 3, 1);
VAR37:=3*VAR35-2*VAR36;
VAR38:=IF(VAR37>80 AND VAR29>88, 0.5, 0);
减四分一:IF((VAR14>50 AND VAR14<100) OR (VAR26+VAR33+VAR38>0), 25, 0), STICK,COLOR8080FF,LINETHICK3;
减三分一:IF(VAR14>100 AND VAR14<200, 33, 0), STICK,COLOR3C6F55,LINETHICK3;
减二分一:IF(VAR14>200, 50, 0), STICK,COLORFF8000,LINETHICK3;
减三分二:IF(VAR1>1.100 AND VAR1<1.150 AND VAR1<REF(VAR1, 1) OR VAR1>1.150 AND VAR1<REF(VAR1, 1), 67, 0), STICK,COLORFF3333,LINETHICK3;
警示:MAX(MAX(减四分一, 减三分一), MAX(减二分一, 减三分二)), POINTDOT,LINETHICK1, COLORRED;

通达信CH盘中警示指标公式源码附图

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: