通达信天量地量指标公式源码附图

  • A+
所属分类:通达信公式

说明:量柱上方.粉红色是三十日天量,黄色是六十日天量,绿色是一百日天量,蓝色是一年天量.
量柱下方,粉红色是三十日地量,黄色是六十日地量,绿色是一百天地量,蓝色是一年地量

M1:=5;
M2:=10;
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL1:=MA(VOLUME,M1);
MAVOL2:=MA(VOLUME,M2);
VAR2:=1*AMOUNT;
MA1:=1*MA(AMOUNT,5);
MA2:=1*MA(AMOUNT,10);
三十日天量:=HHV(VAR2,30)=VAR2;
六十日天量:=HHV(VAR2,60)=VAR2;
百日天量:=HHV(VAR2,100)=VAR2;
一年天量:=HHV(VAR2,250)=VAR2;
STICKLINE(三十日天量,VOLUME,VOLUME*0.7,1,0),COLORMAGENTA;
STICKLINE(六十日天量,VOLUME,VOLUME*0.7,1,0),COLORYELLOW;
STICKLINE(百日天量,VOLUME,VOLUME*0.7,1,0),COLORGREEN;
STICKLINE(一年天量,VOLUME,VOLUME*0.7,1,0),COLORFF7100;
换手:VOL/CAPITAL*100,POINTDOT COLORMAGENTA;
十日换手:SUM(换手,10),COLORGREEN;
二十日换手:SUM(换手,20),COLORFFFFFF;
三十日换手:SUM(换手,30),COLORYELLOW;
三十日地量:=LLV(VAR2,30)=VAR2;
六十日地量:=LLV(VAR2,60)=VAR2;
百日地量:=LLV(VAR2,100)=VAR2;
一年地量:=LLV(VAR2,250)=VAR2;
STICKLINE(三十日地量,-50000,0,1,0),COLORMAGENTA;
STICKLINE(六十日地量,-50000,0,1,0),COLORYELLOW;
STICKLINE(百日地量,-50000,0,1,0),COLORGREEN;
STICKLINE(一年地量,-50000,0,1,0),COLORFF7100;

通达信天量地量指标公式源码附图

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: