通达信CCI爆发体验版副图指标源码

  • A+
所属分类:通达信公式

抄底线:10,COLORYELLOW,LINETHICK2;
 RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
 K:=SMA(RSV,3,1);
 D:=SMA(K,3,1);
 J:=3*K-2*D;
 X:=LLV(J,2)=LLV(J,8);
 RE:=CROSS(J,REF(J+0.01,1)) AND X AND J<19;
 STICKLINE(RE,0,1,3,0),COLORYELLOW;
 CSS:=((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100);
 HH:=CROSS(20,EMA(CSS,3));
 CE:=REF(HH,1);
 AA:=REF(CLOSE,1);
 BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
 HHH:=BBB-LLV(BBB,10);
 SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS)/6;
短线出击:=IF(CROSS(短线买点,1) AND (短线买点<30),30,1);
 II:=短线出击=30;
 TYP:=IF((H>C AND C>O) OR (H>O AND O>=C),C,H)+IF((L<C AND C<O) OR(L<O AND O<=C),CLOSE,LOW)/3;
 CCI:EMA((TYP-MA(TYP,36.0270012))/(0.015*AVEDEV(TYP,36.0270012)),2.0332),COLORGREEN;
 STICKLINE(CCI>100,CCI,100,4,0),COLORMAGENTA;
 STICKLINE(CCI<-150,CCI,-150,4,0),COLORYELLOW;
 STICKLINE(C>0,100,101,10,0),COLORRED;
 STICKLINE(C>0,-150,-151,6,0),COLORGREEN;

VAR1:=HHV(HIGH,9)-LLV(LOW,9);
 VAR2:=HHV(HIGH,9)-CLOSE;
 VAR3:=CLOSE-LLV(LOW,9);
 VAR4:=((VAR2)/(VAR1))*(100)-70;
 VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
 VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
 VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
 VAR8:=LLV(LOW,34);
 VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
 VAR10:=IF((VAR9>100),VAR9-100,0);
 VAR11:=HHV(HIGH,34);
 B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
主力持仓:EMA(B1,20),POINTDOT,COLORRED;
 STICKLINE(B1-主力持仓>0,B1,主力持仓,10,0),COLOR0000FF;
 STICKLINE(B1-主力持仓<0,B1,主力持仓,10,0),COLOR00FF00;

通达信CCI爆发体验版副图指标源码

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: