区间统计 幅图公式 源码 好东西

  • A+
所属分类:通达信公式

区间统计 幅图公式 源码 好东西

统计:=1;始:10;终:=0;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
XZ:=IF(统计=1,1,DRAWNULL);
HSL:=V/FINANCE(7)*10000;
KD1:=(CURRBARSCOUNT=始)*XZ;     ZD1:=(CURRBARSCOUNT-1=终)*XZ;
KD2:=BARSLAST(KD1);          ZD2:=BARSLAST(ZD1);
HS1:=SUM(HSL,KD2+1),NODRAW;
HS2:=IF(ZD2!=0,SUM(HSL,ZD2),0);
QHS:=HS1-HS2,NODRAW;
HH:=CONST(FINDHIGH(H,终,始-终,1));
LL:=CONST(FINDLOW(L,终,始-终,1));
ZF:=(HH/LL-1)*100;
ZFD:(REF(C,终)/REF(C,始)-1)*100,NODRAW;
JC:REF(C,终)-REF(C,始),NODRAW;
始日:=REF(DAY,KD2);
始月:=REF(MONTH,KD2);
始年:=REF(YEAR,KD2);
终日:=REF(DAY,ZD2);
终月:=REF(MONTH,ZD2);
终年:=REF(YEAR,ZD2);
KK1:=STRCAT(STRCAT('起始日期:',CON2STR(始年,0)),'年');
KK2:=STRCAT(CON2STR(始月,0),'月');
KK3:=STRCAT(KK1,KK2);
KK4:=STRCAT(CON2STR(始日,0),'日');
KK5:=STRCAT(KK3,KK4);
ZZ1:=STRCAT(STRCAT('    终止日期:',CON2STR(终年,0)),'年');
ZZ2:=STRCAT(CON2STR(终月,0),'月');
ZZ3:=STRCAT(ZZ1,ZZ2);
ZZ4:=STRCAT(CON2STR(终日,0),'日');
ZZ5:=STRCAT(ZZ3,ZZ4);
KZ:=STRCAT(KK5,ZZ5);
QQ1:=STRCAT('    交易天数:',CON2STR(始-终,0));
QQ2:=STRCAT(STRCAT('    区间换手:',CON2STR(QHS,2)),'%');
QQ3:=STRCAT(QQ1,QQ2);
QQ4:=STRCAT(STRCAT('    区间振幅:',CON2STR(ZF,2)),'%');
QQ5:=STRCAT(QQ3,QQ4);
QQ6:=STRCAT(KZ,QQ5);
WW1:=STRCAT(STRCAT('(',CON2STR(JC,2)),')');
WW2:=STRCAT('    区间涨幅:',WW1);
WW3:=STRCAT(CON2STR(ZFD,2),'%');
WW4:=STRCAT(WW2,WW3);
WW5:=STRCAT('【休闲人区间统计】  ',STRCAT(QQ6,WW4));
DRAWTEXT_FIX(ISLASTBAR AND XZ,0.05,0,0,
'████████████████████████████████████████
████████████████████████████████████████████████████'),COLOR555500;
DRAWTEXT_FIX(ISLASTBAR AND XZ,0.05,0,0,WW5),COLORBBBBBB;
NN:=90;
STICKLINE(KD1,CONST(HHV(H,NN)),CONST(LLV(L,NN)),0,-1),COLOR009FFF;  
STICKLINE(ZD1,CONST(HHV(H,NN)),CONST(LLV(L,NN)),0,-1),COLOR9FFF00;  
DRAWTEXT(KD1,CONST(HHV(H,NN)),'始'),COLOR009FFF;
DRAWTEXT(ZD1,CONST(HHV(H,NN)),'终'),COLOR9FFF00;

 

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: