背离重心雷达操盘线主图指标 源码 通达信 贴图 四大背离精华聚集

  • A+
所属分类:通达信公式

背离重心雷达操盘线主图指标 源码 通达信 贴图 四大背离精华聚集

背离重心雷达操盘线主图指标 源码 通达信 贴图 四大背离精华聚集

背离重心雷达操盘线主图指标 源码 通达信 贴图 四大背离精华聚集

CD3:=REF(C,1);
涨停:=IF((C-CD3)*100/CD3>=(10-0.01*100/CD3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORFF00FF;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
VAR1:=MA(CLOSE,5),COLOR00FFFF;
VAR6:=MA(CLOSE,54),COLORFF9900;
VAR8:= DMA(EMA(CLOSE,12),SUM(VOL/CAPITAL,5)/3),LINETHICK2;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
VARF:=(2*CLOSE+HIGH+LOW)/4;
压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLOR00FF33,LINETHICK1;
支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK1;
支撑价:LLV(LOW,23) ,COLOR7FFF00,LINETHICK2;
阻力价:HHV(HIGH,23),COLORFF9900, LINETHICK1;
VAR10:=LLV(LOW,23);
VAR11:=HHV(HIGH,23);
VAR12:=EMA((VARF-VAR10)/(VAR11-VAR10)*100,6);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,4);
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
持股:IF(MA(CLOSE,7)>REF(MA(CLOSE,7),1),MA(CLOSE,7),DRAWNULL),COLORFF00FF,LINETHICK2;
YYY:=IF(MA(CLOSE,7)=REF(MA(CLOSE,7),1),MA(CLOSE,7),DRAWNULL),COLORYELLOW,LINETHICK3;
空仓:IF(MA(CLOSE,7)<REF(MA(CLOSE,7),1),MA(CLOSE,7),DRAWNULL),COLORGREEN,LINETHICK2;
流通盘:FINANCE(7)/100000000,NODRAW,NODRAW,COLORRED;
市盈率:DYNAINFO(39),NODRAW,COLORGREEN;
净资产:FINANCE(34),NODRAW,COLORYELLOW;
每股收益:FINANCE(30)/FINANCE(1),NODRAW,COLORFF00FF;
DRAWTEXT(REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA")>0,L-0.3,'MACD底背离'),COLOR00FFFF;
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
DRAWTEXT(REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D"),L-0.20,'KDJ底背离'),COLORFF00FF;
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
DRAWTEXT(REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2")>0,L-0.5,'RSI底背离'),COLOR0000FF;
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
DRAWTEXT(REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF")>0,H+0.3,'MACD顶背离'),COLOR00FF00;
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
DRAWTEXT(REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K")>0,H+0.2,'KDJ顶背离'),COLORFFFFCC;
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
DRAWTEXT(REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1")>0,H+0.4,'RSI顶背离'),COLORFF9900;
重心:= (C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
操盘线:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;
黄金线:IF(重心>=操盘线,操盘线,DRAWNULL),COLORRED,LINETHICK2;
空仓线:IF(重心<操盘线,操盘线,DRAWNULL),COLORCYAN,LINETHICK2;
DRAWTEXT(ISLASTBAR,操盘线,'操盘线'),COLORRED;
WWWCHNMONEYCOM:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
变:EMA(CLOSE,5),LINETHICK2,COLORWHITE;
金:IF(变>REF(变,1),变,DRAWNULL),COLORRED,LINETHICK2;
空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR,变,'雷达线'),COLORRED;

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: