资金拉升副图指标 源码 通达信 贴图

  • A+
所属分类:通达信公式

资金拉升副图指标 源码 通达信 贴图

资金拉升副图指标 源码 通达信 贴图

总亿:AMOUNT/100000000,COLORFF00FF,NODRAW;
VAR1:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
流入亿:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+ (CLOSE-LOW)),AMOUNT/2))/100000000,COLORRED,NODRAW;
流出亿:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN- LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-AMOUNT/2))/100000000,COLOR00FF00,NODRAW;
额亿:流入亿+流出亿,COLORFFFF00,NODRAW;
{线:=MA(CLOSE,1)-MA(CLOSE,6),NODRAW;}
YUWEI:=MA(CLOSE,1)-MA(CLOSE,6),NODRAW;
{量:(线),VOLSTICK;}
分界:0;
STICKLINE(YUWEI>0 AND YUWEI>REF(YUWEI,1),0,YUWEI,4,0)COLOR0D0C6A;
STICKLINE(YUWEI>0 AND YUWEI>REF(YUWEI,1),0,YUWEI,3,0)COLOR0D06AA;
STICKLINE(YUWEI>0 AND YUWEI>REF(YUWEI,1),0,YUWEI,1.5,0)COLOR2108C1;
STICKLINE(YUWEI>0 AND YUWEI>REF(YUWEI,1),0,YUWEI,0.5,0)COLOR9F5DFF;
STICKLINE(YUWEI>0 AND YUWEI<REF(YUWEI,1),0,YUWEI,4,0)COLOR22736F;
STICKLINE(YUWEI>0 AND YUWEI<REF(YUWEI,1),0,YUWEI,3,0)COLOR22AAD5;
STICKLINE(YUWEI>0 AND YUWEI<REF(YUWEI,1),0,YUWEI,1.5,0)COLOR10C7BF;
STICKLINE(YUWEI>0 AND YUWEI<REF(YUWEI,1),0,YUWEI,0.5,0)COLOR80FFFF;
STICKLINE(YUWEI<0 AND YUWEI<REF(YUWEI,1),0,YUWEI,4,0)COLOR1B7411;
STICKLINE(YUWEI<0 AND YUWEI<REF(YUWEI,1),0,YUWEI,3,0)COLOR17A715;
STICKLINE(YUWEI<0 AND YUWEI<REF(YUWEI,1),0,YUWEI,1.5,0)COLOR08D306;
STICKLINE(YUWEI<0 AND YUWEI<REF(YUWEI,1),0,YUWEI,0.5,0)COLOR40FF00;
STICKLINE(YUWEI<0 AND YUWEI>REF(YUWEI,1),0,YUWEI,4,0)COLOR080E71;
STICKLINE(YUWEI<0 AND YUWEI>REF(YUWEI,1),0,YUWEI,3,0)COLOR0B0E8C;
STICKLINE(YUWEI<0 AND YUWEI>REF(YUWEI,1),0,YUWEI,1.52,0)COLOR0905B0;
STICKLINE(YUWEI<0 AND YUWEI>REF(YUWEI,1),0,YUWEI,0.5,0)COLOR0204F2;
{趋势}
主力:=(CLOSE*2+HIGH+LOW+O)/4;
散户:=EMA(主力,11)-EMA(主力,22);
量比:=EMA(散户,5);
量: (-2)*(散户-量比)*5,COLORWHITE,LINETHICK1;
量1: 2*(散户-量比)*5,COLOR0000FF,LINETHICK1;
轴:0;
X_1:=1;
X_2:=1/WINNER(CLOSE);
X_3:=MA(CLOSE,13);
X_4:=100-ABS((CLOSE-X_3)/X_3*100);
X_5:=LLV(LOW,75);
X_6:=HHV(HIGH,75);
X_7:=(X_6-X_5)/100;
X_8:=SMA((CLOSE-X_5)/X_7,21,1);
X_9:=SMA((OPEN-X_5)/X_7,21,1);
X_10:=3*X_8-2*SMA(X_8,13,1);
X_11:=3*X_9-2*SMA(X_9,13,1);
X_12:=100-X_11;
X_13:=MA(CLOSE,60);
X_14:=IF(DATE<=1371030,1,0);
X_15:=MA(WINNER(CLOSE*0.95)*100,3)*X_1;
X_16:=(100-X_10)*X_1;
X_17:=CLOSE=HHV(CLOSE,20);
X_18:=BARSLAST(X_17);
X_19:=IF(X_18>0,REF(CLOSE,X_18),REF(CLOSE,X_18));
X_20:=CROSS(CLOSE,REF(X_19,1));
X_21:=X_20*X_14 AND CROSS(X_15,X_16)*X_14 AND MACD.DIF>MACD.DEA*X_14 AND COUNT(X_20,5)=1*X_14 AND VOL>REF(VOL,1)*X_14 AND REF(MACD.DIF,1)>REF(MACD.DIF,2)*X_14 AND REF(X_13,3)<REF(X_13,2)*X_14 AND REF(X_13,2)<REF(X_13,1)*X_14 AND X_13>REF(X_13,1)*X_14 AND CLOSE>OPEN*X_14;
阴线进:REF(X_21=1,1)*X_14 AND CLOSE<REF(CLOSE,1)*X_14,COLORRED,LINETHICK2;
DRAWICON(阴线进,0.6,9);
DRAWICON(阴线进,1.2,1);

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: